"The file specified is not a MicroKernel file."

Either the file is corrupt, or it is was created in an older version of Pervasive and is not compatible with the new version.

Resolution:

See the knowledge base article on Recovering a File.

If the file was created using an older version of Pervasive, it will need to be rebuilt in to a file that is the correct version. Contact KSS tech support for this assistance.